Счастливый новый PHP: Взгляд на WordPress ‘Недавний прыжок в минимальных требованиях PHP

Что касается языков программирования идти, PHP получает крупные обновления довольно часто. Это означает, что со временем WordPress необходимо обновить минимальную необходимую версию PHP, чтобы идти в ногу с этими обновлениями и предоставлять пользователям лучший опыт.

Пока вы читаете это, WordPress делает скачок к версии PHP 5.6. Это не последняя версия PHP, но это все еще серьезное изменение, которое повлияет на то, как пользователи WordPress делать вещи. Там нет необходимости беспокоиться, хотя: это обновление является хорошей вещью.

В этой статье мы собираемся сломать аргументы в отношении скачка в минимальных требованиях PHP. Затем мы объясним, как использование этой новой версии PHP повлияет на вас, и как обновить до новой версии. Давайте поговорим PHP!

WordPress’ Перейти в минимальных требованиям PHP Разъяснения

На некоторое время теперь, WordPress ‘минимум PHP версия требование было установлено в версиях 5.2-5.5. Еще в декабре 2018 года было предложено обновить минимальное требование PHP к версии 5.6 в апреле 2019 года, чтобы побудить пользователей WordPress к внедрению более безопасных и более эффективных версий.

Изменение минимальных требований в первую очередь направлено на пользователей, которые могут не знать, что они заражаются версиями. Оповещения о новых требованиях будут информировать менее опытных пользователей о необходимости обновления PHP, что, как мы надеемся, приведет их к переходу на версию, которая имеет лучшую безопасность, производительность и поддержку.

Так как изменение было объявлено, многие люди поставили под сомнение ли это не будет лучше, чтобы перейти к версии PHP 7, по крайней мере. В конце концов, 5.6 не совсем недавний релиз.

Однако, чтобы понять, почему изменения должны быть постепенными, нам необходимо взглянуть на некоторые цифры. Статистика показывает, что около 20% пользователей по-прежнему работают PHP версии в диапазоне от 5,2 до 5,5, что не является незначительным показателем.

На некоторое время теперь, WordPress нажимает потребителей для того чтобы уточнить наши версии PHP,и bumping минимальное требование правоподобно для того чтобы ускорить процесс. Медленное увеличение требований должно облегчить пользователям старых версий PHP постепенноватомв вносить изменения и обеспечивать, чтобы их сайты оставались нетронутыми.

Если все пойдет хорошо, Есть уже планы на месте, чтобы bump WordPress ‘минимальные требования PHP вплоть до версии 7 к декабрю 2019 года. Тем не менее, ничто не мешает вам обновить до последней версии PHP сейчас, если вы хотите.

Как переход в минимальных требованиях PHP повлияет на вас

Обновление версии PHP предлагает многочисленные преимущества. Те, кто в настоящее время работает старые версии и обновления для удовлетворения новых минимальных требований должны увидеть улучшения в безопасности и производительности. Они также получат доступ к дополнительным функциям и поддержке.

Для разработчиков, обновления WordPress ‘минимум PHP версии, мы надеемся, означает меньше головных болей. Например, разработчикам плагинов не нужно иметь дело с таким количеством запросов поддержки от пользователей, которые придерживаются изысканных версий или имеют проблемы сосовместимости.

Если у вас были клиенты или пользователи, которые настаивали на цеплянии за старые версии PHP, теперь у вас будет веская причина настаивать на обновлении. Это даст вам доступ к широкому спектру дополнительных функций разработки, доступных в новых версиях PHP, что делает вашу работу проще (и, надеюсь, больше удовольствия!).

Разработчики, которые имеют несколько сайтов работает устаревшие версии PHP – либо из-за пожеланий клиентов или потому, что они получили немного позади на обновления – будет иметь довольно много работы на их руках, прежде чем они могут пожинать эти преимущества. Если вы находитесь в этой ситуации, попробуйте посмотреть в ли ваш веб-хостинг может помочь вам обновить без особой суеты.

Как обновить версию PHP

Мы говорили в прошлом о том, как обновить версию PHP. Вот краткое резюме:

  1. Резервное копирование веб-сайта и обновить все его компоненты.
  2. Используйте плагин, чтобы проверить ваш сайт на наличие проблем совместимостью с новыми версиями PHP.
  3. Обновление до новой версии.
  4. Проверьте свой сайт на наличие нежелательных изменений, связанных с обновлением.

В большинстве случаев вы можете переключиться на новые версии PHP прямо с панели мониторинга хостинга, если ваш провайдер поддерживает желаемую версию. В эти дни, поддержка PHP 7 является довольно распространенным явлением, поэтому мы рекомендуем вам пропустить право на него.

Независимо от версии вы решили обновить, убедитесь, что не пропустить шаги один и два процесса мы изложили минуту назад. Они не являются строго необходимыми, но они не должны занять много времени, и они помогут вам убедиться, что переход проходит гладко.

Заключение

Обновление к версии WordPress минимальная PHP превосходная новость для вас как проявителя. С места в карьер, это означает, что вам не нужно будет поддерживать, как многие пользователи, которые все еще работает наследие PHP версий. Это обновление в прямом эфире сейчас, так что мы должны начать пожинать плоды в ближайшее время.

То, что мы действительно рады, однако, является предлагаемый переход к версии PHP 7 к концу года. Как вы знаете, версия 7 принесла с собой массовое увеличение производительности, и мы пытались убедить людей перейти к нему на некоторое время.

Есть ли у вас какие-либо вопросы о том, что скачок в WordPress минимальные требования PHP означает для вас? Давайте поговорим о них в разделе комментариев ниже!

Изображение кредита: Pixabay.

Источник: torquemag.io

Добавить комментарий

%d такие блоггеры, как: